Thu, 13 Aug 2020 14:34:00 CDT | login

Information for build lcmaps-1.6.6-1.8.osg34.el7

ID11164
Package Namelcmaps
Version1.6.6
Release1.8.osg34.el7
Epoch
SummaryGrid (X.509) and VOMS credentials to local account mapping service
DescriptionThe Local Centre MAPping Service (LCMAPS) is a security middleware component that processes the users Grid credentials (typically X.509 proxy certificates and VOMS attributes) and maps the user to a local account based on the site local policy. It is a highly configurable pluggable interface, and many plugins are available to tailor almost every need. Since this is middleware, it does not interact with the user directly; to use it in a program please see the lcmaps-interface package.
Built byMatyas Selmeci A148276
State complete
Volume DEFAULT
StartedTue, 17 Oct 2017 15:28:18 CDT
CompletedTue, 17 Oct 2017 15:38:34 CDT
Taskbuild (osg-el7, /svn/native/redhat/trunk/lcmaps:23891)
Tags
osg-3.4-el7-development
osg-3.4-el7-release
osg-3.4-el7-release-3.4.10
osg-3.4-el7-release-3.4.11
osg-3.4-el7-release-3.4.12
osg-3.4-el7-release-3.4.13
osg-3.4-el7-release-3.4.14
osg-3.4-el7-release-3.4.15
osg-3.4-el7-release-3.4.16
osg-3.4-el7-release-3.4.17
osg-3.4-el7-release-3.4.18
osg-3.4-el7-release-3.4.19
osg-3.4-el7-release-3.4.20
osg-3.4-el7-release-3.4.21
osg-3.4-el7-release-3.4.22
osg-3.4-el7-release-3.4.23
osg-3.4-el7-release-3.4.24
osg-3.4-el7-release-3.4.25
osg-3.4-el7-release-3.4.26
osg-3.4-el7-release-3.4.27
osg-3.4-el7-release-3.4.28
osg-3.4-el7-release-3.4.29
osg-3.4-el7-release-3.4.30
osg-3.4-el7-release-3.4.31
osg-3.4-el7-release-3.4.32
osg-3.4-el7-release-3.4.33
osg-3.4-el7-release-3.4.34
osg-3.4-el7-release-3.4.35
osg-3.4-el7-release-3.4.5
osg-3.4-el7-release-3.4.50
osg-3.4-el7-release-3.4.51
osg-3.4-el7-release-3.4.52
osg-3.4-el7-release-3.4.53
osg-3.4-el7-release-3.4.6
osg-3.4-el7-release-3.4.7
osg-3.4-el7-release-3.4.8
osg-3.4-el7-release-3.4.9
osg-3.4-el7-testing
RPMs
src
lcmaps-1.6.6-1.8.osg34.el7.src.rpm (info) (download)
x86_64
lcmaps-1.6.6-1.8.osg34.el7.x86_64.rpm (info) (download)
lcmaps-common-devel-1.6.6-1.8.osg34.el7.x86_64.rpm (info) (download)
lcmaps-db-templates-1.6.6-1.8.osg34.el7.x86_64.rpm (info) (download)
lcmaps-devel-1.6.6-1.8.osg34.el7.x86_64.rpm (info) (download)
lcmaps-without-gsi-1.6.6-1.8.osg34.el7.x86_64.rpm (info) (download)
lcmaps-without-gsi-devel-1.6.6-1.8.osg34.el7.x86_64.rpm (info) (download)
lcmaps-debuginfo-1.6.6-1.8.osg34.el7.x86_64.rpm (info) (download)
Logs
x86_64
root.log
state.log
build.log
Changelog * Tue Oct 17 2017 Mátyás Selmeci <matyas@cs.wisc.edu> 1.6.6-1.8 - Add vomsmap template with -all-fqans (SOFTWARE-2932) * Thu Oct 12 2017 Mátyás Selmeci <matyas@cs.wisc.edu> 1.6.6-1.7 - Add comments about -all-fqans to lcmaps.db templates (SOFTWARE-2932) * Tue May 23 2017 Brian Lin <blin@cs.wisc.edu> 1.6.6-1.6 - Drop LCMAPS GUMS client plugins dependency (SOFTWARE-2681) * Fri May 19 2017 Brian Lin <blin@cs.wisc.edu> 1.6.6-1.5 - Drop GRAM conflicts (SOFTWARE-2681) * Mon Apr 24 2017 Mátyás Selmeci <matyas@cs.wisc.edu> 1.6.6-1.4.osgup - Drop glexec templates (SOFTWARE-2692) * Thu Apr 20 2017 Mátyás Selmeci <matyas@cs.wisc.edu> 1.6.6-1.3.osg33 - Add template lcmaps.db files under /usr/share/lcmaps/templates (SOFTWARE-2692) * Mon Mar 20 2017 Mátyás Selmeci <matyas@cs.wisc.edu> 1.6.6-1.3.osgup - Remove defaultnovomscheck.patch (SOFTWARE-2634) * Thu Feb 23 2017 Mátyás Selmeci <matyas@cs.wisc.edu> 1.6.6-1.2.osg - Add ban-mapfile, ban-voms-mapfile and updated lcmaps.db with a new authorize_only policy that uses the ban files, voms mapfiles, and a modified verify_proxy. This adds new requirements on: - lcmaps-plugins-voms >= 1.7.1-1.1 - lcmaps-plugins-verify-proxy >= 1.5.9-1.1 (SOFTWARE-2602) * Thu Apr 30 2015 Matyas Selmeci <matyas@cs.wisc.edu> 1.6.6-1.1.osg33 - [build for osg 3.3 found on this date -matyas 02/23/17] * Tue Mar 24 2015 Dave Dykstra <dwd@fnal.gov> 1.6.6-1.1.osg32 - [build for osg 3.2 found on this date -matyas 02/23/17] * Wed Feb 18 2015 Mischa Salle <msalle@nikhef.nl> 1.6.6-1 - updated version - update globus dependencies * Wed Dec 10 2014 Dave Dykstra <dwd@fnal.gov> 1.6.4-1.3.osg - Updated defaultnovomscheck.patch for current source code context. Apparently the el5 patch was forgiving enough so as to not notice. * Tue Dec 09 2014 Dave Dykstra <dwd@fnal.gov> 1.6.4-1.2.osg - Removed requirement of lcmaps-plugins-saz-client * Tue Dec 09 2014 Dave Dykstra <dwd@fnal.gov> 1.6.4-1.1.osg - Reimported upstream version into OSG * Tue Mar 04 2014 Mischa Salle <msalle@nikhef.nl> 1.6.5-1 - updated version - do not install very old doc/INSTALL_WITH_WORKSPACE_SERVICE - install NEWS file * Fri Feb 28 2014 Mischa Salle <msalle@nikhef.nl> 1.6.4-1 - updated version - do not install very old doc/INSTALL_WITH_WORKSPACE_SERVICE * Sun Feb 16 2014 Mischa Salle <msalle@nikhef.nl> 1.6.3-2 - fix macro expansion for pkgconfig to include only rhel not fedora * Thu Feb 13 2014 Mischa Salle <msalle@nikhef.nl> 1.6.3-1 - updated version * Fri Feb 07 2014 Mischa Salle <msalle@nikhef.nl> 1.6.2-1 - Add new interface files - Remove unused patch - Create empty plugin directory - Do not remove lcmaps_plugin_example related files, as they are not installed - updated version * Tue Nov 12 2013 Dennis van Dok <dennisvd@nikhef.nl> 1.6.1-6 - Make requirements arch-specific for devel package * Mon Nov 11 2013 Dennis van Dok <dennisvd@nikhef.nl> 1.6.1-5 - put BuildRoot and clean section back in for EPEL5 - Add requirement on pkgconfig for EPEL5 - Include Provides/Obsoletes to rename interface packages * Wed Oct 30 2013 Dennis van Dok <dennisvd@nikhef.nl> 1.6.1-3 - Reduced the number of development packages * Wed Oct 23 2013 Dennis van Dok <dennisvd@nikhef.nl> 1.6.1-2 - Renamed the -interface packages to -devel - Dropped buildroot and defattr * Wed Feb 27 2013 Mischa Salle <msalle@nikhef.nl> 1.6.1-1 - install BUGS as doc - updated version * Tue Feb 26 2013 Mischa Salle <msalle@nikhef.nl> 1.6.0-1 - updated version * Thu Feb 21 2013 Dave Dykstra <dwd@fnal.gov> 1.5.7-1.4.osg - Remove the osg_default policy from lcmaps.db since it is no longer used by any application * Thu Jan 10 2013 Dave Dykstra <dwd@fnal.gov> 1.5.7-1.3.osg - Back out the changes of 1.5.7-1.2.osg for now * Wed Jan 02 2013 Dave Dykstra <dwd@fnal.gov> 1.5.7-1.2.osg - Move lcmaps.db and Requires of lcmaps plugins to new osg-lcmaps metapackage * Wed Jan 02 2013 Dave Dykstra <dwd@fnal.gov> 1.5.7-1.1.osg - Import latest upstream version - Remove references to /usr/lib64/modules and %ghost files * Thu Dec 06 2012 Dave Dykstra <dwd@fnal.gov> 1.5.4-1.5.osg - Remove accidentally-added "{(x86-64)}" junk on Requires statements * Thu Dec 06 2012 Dave Dykstra <dwd@fnal.gov> 1.5.4-1.4.osg - Prevent printing an error "mv: cannot stat `*': No such file or directory" when /usr/lib64/modules is empty * Tue Oct 23 2012 Mischa Salle <msalle@nikhef.nl> 1.5.7-1 - Do not install INSTALL in doc. - Update URL. - updated version * Fri Sep 14 2012 Dave Dykstra <dwd@fnal.gov> 1.5.4-1.3.osg - Prevent the movement of files from the old /usr/lib64/modules directory to /usr/lib64/lcmaps from overwriting anything that was already there * Fri Jul 06 2012 Mischa Salle <msalle@nikhef.nl> 1.5.6-1 - updated version * Fri Jun 15 2012 Dave Dykstra <dwd@fnal.gov> 1.5.4-1.2.osg - Add authorize_only policy to default lcmaps.db, for Condor * Mon Apr 23 2012 Dave Dykstra <dwd@fnal.gov> 1.5.4-1.1.osg - Reimported from upstream, fixes bug with parsing that caused unmatched quotes in lcmaps.db to trigger an 'out of memory' error * Mon Apr 23 2012 Mischa Salle <msalle@nikhef.nl> 1.5.5-1 - build both with and without gsi packages in one spec file - updated version * Wed Apr 18 2012 Dave Dykstra <dwd@fnal.gov> 1.5.3-1.3.osg - Add patch to change the default voms certificate check to be off, but still possible to be enabled at run time * Wed Apr 18 2012 Matyas Selmeci <matyas@cs.wisc.edu> 1.5.3-1.2.osg - Added fix for /usr/lib64/modules conflict between lcmaps and the plugins * Mon Mar 26 2012 Mischa Salle <msalle@nikhef.nl> 1.5.4-1 - updated version * Mon Mar 19 2012 Dave Dykstra <dwd@fnal.gov> 1.5.3-1.1.osg - Reimported into OSG, removed the temporary patch * Fri Mar 16 2012 Mischa Salle <msalle@nikhef.nl> 1.5.3-1 - updated version * Mon Mar 12 2012 Dave Dykstra <dwd@fnal.gov> 1.5.2-2.4.osg - Add temporary patch to turn "error:storing gss_credential or its derivative credentials" into a warning when grid-proxy-init is used instead of voms-proxy-init. * Fri Mar 09 2012 Dave Dykstra <dwd@fnal.gov> 1.5.2-2.3.osg - Update the default lcmaps.db to give 3 policy options for the osg_default policy exactly like there was for glexec * Thu Mar 08 2012 Dave Dykstra <dwd@fnal.gov> 1.5.2-2.2.osg - Rebuild for trunk * Fri Feb 17 2012 Dave Dykstra <dwd@fnal.gov> 1.5.2-2.1.osg - Updated upstream version * Mon Jan 30 2012 Mischa Salle <msalle@nikhef.nl> 1.5.2-3 - add manpage in main package - updated version * Fri Dec 30 2011 Dave Dykstra <dwd@fnal.gov> 1.5.0-1.1.osg - Re-import to OSG, applying still-relevant OSG modifications - Update default lcmaps.db with new glexectracking options and with combined osg_default rule for gridftp & gatekeeper * Wed Dec 14 2011 Mischa Salle <msalle@nikhef.nl> 1.5.0-1 * Tue Sep 20 2011 Mischa Salle <msalle@nikhef.nl> 1.4.33-1 - updated version - added obsoletes for lcmaps-interface * Fri Sep 16 2011 Mischa Salle <msalle@nikhef.nl> 1.4.32-1 - updated version * Tue Sep 13 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.31-5 - Repaired the unintended post macro in the changelog * Wed Aug 10 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.31-4 - Split interface according to dependencies on globus and openssl * Wed Jul 20 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.30-2 - Moved the .so files to the runtime package as these are dlopened * Wed Jul 13 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.30-1 - updated version * Mon Jul 04 2011 Mattias Ellert <mattias.ellert@fysast.uu.se> - 1.4.29-2 - Make interface package noarch - Remove Vendor tag * Mon Jul 04 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.29-1 - Updated version * Wed Mar 23 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.28-2 - removed explicit requires * Wed Mar 09 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.28-1 - Made examples out of config files * Tue Mar 08 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.27-2 - Disable rpath in configure * Mon Mar 07 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.27-1 - Fixed globus dependencies - added ldconfig to post and postun section * Fri Mar 04 2011 Dennis van Dok <dennisvd@nikhef.nl> 1.4.26-3 - disabled static libraries - added proper base package requirement for devel - fixed license string * Mon Feb 21 2011 Dennis van Dok <dennisvd@nikhef.nl> - Initial build.