Wed, 25 May 2022 21:37:59 CDT | login

Information for build lcmaps-plugins-scas-client-0.4.0-1.2.osg31.el6

ID4657
Package Namelcmaps-plugins-scas-client
Version0.4.0
Release1.2.osg31.el6
Epoch
SummarySCAS client plugin for the LCMAPS authorization framework
DescriptionThe Local Centre MAPping Service (LCMAPS) is a security middleware component that processes the users Grid credentials (typically X.509 proxy certificates and VOMS attributes) and maps the user to a local account based on the site local policy. This package contains the SCAS client plug-in. This LCMAPS plugin functions as the PEP (client side) implementation to an Site Central Authorization Service (SCAS) or GUMS (new style) service.
Built by(disabled) Dave Dykstra 508
State complete
Volume DEFAULT
StartedThu, 23 Jan 2014 15:34:22 CST
CompletedThu, 23 Jan 2014 15:38:52 CST
Taskbuild (osg-3.1-el6, /svn/native/redhat/branches/osg-3.1/lcmaps-plugins-scas-client:18635)
Tags No tags
RPMs
src
lcmaps-plugins-scas-client-0.4.0-1.2.osg31.el6.src.rpm (info) (download)
i386
lcmaps-plugins-saz-client-0.4.0-1.2.osg31.el6.i386.rpm (info) (download)
lcmaps-plugins-scas-client-0.4.0-1.2.osg31.el6.i386.rpm (info) (download)
lcmaps-plugins-scas-client-debuginfo-0.4.0-1.2.osg31.el6.i386.rpm (info) (download)
x86_64
lcmaps-plugins-saz-client-0.4.0-1.2.osg31.el6.x86_64.rpm (info) (download)
lcmaps-plugins-scas-client-0.4.0-1.2.osg31.el6.x86_64.rpm (info) (download)
lcmaps-plugins-scas-client-debuginfo-0.4.0-1.2.osg31.el6.x86_64.rpm (info) (download)
Logs
x86_64
root.log
state.log
build.log
i386
root.log
state.log
build.log
Changelog * Thu Jan 23 2014 Dave Dykstra <dwd@fnal.gov> 0.4.0-1.2.osg - Add patch from upstream to show SSL error queue when there is an openssl error * Wed Oct 09 2013 Dave Dykstra <dwd@fnal.gov> 0.4.0-1.1.osg - Reimported into OSG - Removed log_xacml_errors.patch * Fri Oct 04 2013 Mischa Salle <msalle@nikhef.nl> 0.4.0-1 - update build requirement on xacml-devel plus minimal version - add requirement on xacml plus minimal version - bumped version * Thu Oct 03 2013 Mischa Salle <msalle@nikhef.nl> 0.3.5-1 - installed BUGS as documentation - add requirement on LCMAPS plus minimal version - use mandir for installing man pages - bumped version * Mon Sep 16 2013 Brian Bockelman <bbockelm@cse.unl.edu> 0.3.4-1.3.osg - Log libxacml failures. * Thu Dec 27 2012 Dave Dykstra <dwd@fnal.gov> 0.3.4-1.2.osg - Remove /usr/lib64/modules symlink and %ghost files - Include a .so in lcmaps-plugins-saz-client package like all the other plugins have, and a symlink at .mod * Thu Mar 15 2012 Dave Dykstra <dwd@fnal.gov> 0.3.4-1.1.osg - Reimported to OSG - Removed keepalive patch * Thu Mar 08 2012 Mischa Salle <msalle@nikhef.nl> 0.3.4-1 - bumped version * Thu Mar 08 2012 Dave Dykstra <dwd@fnal.gov> 0.3.3-1.3.osg - Rebuild after merging from branches/lcmaps-upgrade into trunk * Wed Feb 29 2012 Dave Dykstra <dwd@fnal.gov> 0.3.3-1.2.osg - Add enablekeepalive patch to turn on the --enable-keepalive option by default. This is temporary until upstream enables it by default. * Tue Feb 28 2012 Dave Dykstra <dwd@fnal.gov> 0.3.3-1.1.osg - Upgraded upstream package, which adds certificate valid date messages to the authorization server for use by SAZ * Tue Feb 28 2012 Mischa Salle <msalle@nikhef.nl> 0.3.3-1 - bumped version * Tue Feb 21 2012 Dave Dykstra <dwd@fnal.gov> 0.3.2-1.1.osg - Upgraded upstream package - Removed memory_corruption and fix_loglevels.patch * Mon Feb 20 2012 Mischa Salle <msalle@nikhef.nl> 0.3.2-1 - bumped version * Mon Jan 16 2012 Dave Dykstra <dwd@fnal.gov> 0.3.0-1.3.osg - Rebuild to get package signed * Fri Jan 13 2012 Dave Dykstra <dwd@fnal.gov> 0.3.0-1.2.osg - Just a rebuild. It turned out that I had forgotten to add the 'Requires: saml2-xacml2-c-lib' which is just as well because I can't reproduce the problem with the hadoop repo anymore. This rebuild is mainly to document this fact. * Fri Dec 30 2011 Dave Dykstra <dwd@fnal.gov> 0.3.0-1.1.osg - Imported into OSG - Added "Requires: saml2-xacml2-c-lib", instead of the implicit requirement of libxacml.so which sometimes instead picks up prima from hadoop repo - Included ca_only.patch to fix a SEGV when no user certificate is present. - Included memory_corrupt.patch to fix a memory corruption issue on an error condition. - Added fix_loglevels.patch to complete conversion to new lcmaps_log levels - Added subpackage lcmaps-plugins-saz-client - Added %ghost for plugin files in modules directory so they won't get deleted in an upgrade (since modules is now a symlink). * Fri Dec 16 2011 Mischa Salle <msalle@nikhef.nl> 0.3.0-1 - bumped version - updated installation dir plugins and removed .so.0* files * Wed Apr 06 2011 Dennis van Dok <dennisvd@nikhef.nl> 0.2.22-1 - bumped version * Wed Mar 23 2011 Dennis van Dok <dennisvd@nikhef.nl> 0.2.21-2 - removed explicit requires * Mon Mar 07 2011 Dennis van Dok <dennisvd@nikhef.nl> 0.2.21-1 - added openssl dependency * Fri Mar 04 2011 Dennis van Dok <dennisvd@nikhef.nl> 0.2.20-2 - fixed license string - dropped devel package - disable static libraries * Mon Feb 21 2011 Dennis van Dok <dennisvd@nikhef.nl> - Initial build.